近期运维一台服务器(Dell PowerEdge R910),发现没有服务器健康监控面板,运维十分痛苦。于是打算安装Dell官方提供的服务器管理工具。OMSA: Openmanage Server Administrator;PVE: Proxmox Virtual Environment。

原理?安装前的说明。

OMSA在Dell官网可以很容易下载到,不过只提供了Windows版本和Redhat(CentOS)版本,而且官方说法,新版OMSA不支持R910(我不信邪),大概是Dell懒得做适配和维护。

网上有许多PVE6.x/Debian10的OMSA的安装教程了,我也就是站在前人的基础上,做个升级的操作。

安装过程就是使用Dell EMC OpenManage Ubuntu and Debian Repositories(官方)源,安装OMSA,不过由于OMSA比较新的版本没有适配Debian,使用这个源(等于使用Ubuntu的源),得事先处理一些依赖的问题。

注:虽然在Debian使用Ubuntu源十分野蛮,不过重点在于结果而不在于过程,只是利用到了这个源的便利性,安装完毕即可删除源。

不过毕竟已经从Debian10到了Debian11,老的OMSA版本就不适用了,于是直接使用支持Ubuntu focal的版本10.01。

开始安装

注:以下命令均在root用户下执行

添加源gpg秘钥

wget https://linux.dell.com/repo/pgp_pubkeys/0x1285491434D8786F.asc && \
apt-key add 0x1285491434D8786F.asc

添加Dell Linux源

echo "deb http://linux.dell.com/repo/community/openmanage/1001/focal focal main" > /etc/apt/sources.list.d/linux.dell.com.sources.list && \
apt update

安装依赖

wget http://archive.ubuntu.com/ubuntu/pool/universe/o/openwsman/libwsman-curl-client-transport1_2.6.5-0ubuntu3_amd64.deb && \
wget http://archive.ubuntu.com/ubuntu/pool/universe/o/openwsman/libwsman-client4_2.6.5-0ubuntu3_amd64.deb &&\
wget http://archive.ubuntu.com/ubuntu/pool/universe/o/openwsman/libwsman1_2.6.5-0ubuntu3_amd64.deb &&\
wget http://archive.ubuntu.com/ubuntu/pool/universe/o/openwsman/libwsman-server1_2.6.5-0ubuntu3_amd64.deb && \
wget http://archive.ubuntu.com/ubuntu/pool/universe/s/sblim-sfcc/libcimcclient0_2.2.8-0ubuntu2_amd64.deb && \
wget http://archive.ubuntu.com/ubuntu/pool/universe/o/openwsman/openwsman_2.6.5-0ubuntu3_amd64.deb && \
wget http://archive.ubuntu.com/ubuntu/pool/multiverse/c/cim-schema/cim-schema_2.48.0-0ubuntu1_all.deb && \
wget http://archive.ubuntu.com/ubuntu/pool/universe/s/sblim-sfc-common/libsfcutil0_1.0.1-0ubuntu4_amd64.deb && \
wget http://archive.ubuntu.com/ubuntu/pool/multiverse/s/sblim-sfcb/sfcb_1.4.9-0ubuntu5_amd64.deb && \
wget http://archive.ubuntu.com/ubuntu/pool/universe/s/sblim-cmpi-devel/libcmpicppimpl0_2.0.3-0ubuntu2_amd64.deb && \
dpkg -i libwsman-curl-client-transport1_2.6.5-0ubuntu3_amd64.deb && \
dpkg -i libwsman-client4_2.6.5-0ubuntu3_amd64.deb && \
dpkg -i libwsman1_2.6.5-0ubuntu3_amd64.deb && \
dpkg -i libwsman-server1_2.6.5-0ubuntu3_amd64.deb && \
dpkg -i libcimcclient0_2.2.8-0ubuntu2_amd64.deb && \
dpkg -i openwsman_2.6.5-0ubuntu3_amd64.deb && \
dpkg -i cim-schema_2.48.0-0ubuntu1_all.deb && \
dpkg -i libsfcutil0_1.0.1-0ubuntu4_amd64.deb && \
dpkg -i sfcb_1.4.9-0ubuntu5_amd64.deb && \
dpkg -i libcmpicppimpl0_2.0.3-0ubuntu2_amd64.deb && \
apt install libncurses5 libcurl4 libgpm2 libtinfo5

安装以及启动srvadmin(OMSA)

apt install srvadmin-all -y 
touch /opt/dell/srvadmin/lib64/openmanage/IGNORE_GENERATION #忽略更新
/opt/dell/srvadmin/sbin/srvadmin-services.sh enable && /opt/dell/srvadmin/sbin/srvadmin-services.sh start #启动服务

参考

  • https://forum.proxmox.com/threads/dell-openmanage-on-proxmox-6-x.57932/
  • https://linux.dell.com/repo/community/openmanage/

EOF

说点什么
支持Markdown语法
好耶,沙发还空着ヾ(≧▽≦*)o
Loading...